Back to overview
Degraded

Errors due to AWS outage

Oct 20 at 09:00am PDT
Affected services
Web Application
Backend Systems

Resolved
Oct 20 at 05:28pm PDT

Upstream issues with AWS have been resolved and our systems are now functioning normally.

Updated
Oct 20 at 12:15pm PDT

We are seeing elevated errors in new logins. Users not already logged in are unable to log into the application. This is due to issues faced by our upstream authentication provider.

Created
Oct 20 at 09:00am PDT

We are currently experiencing a service disruption due to an ongoing AWS outage affecting several of our systems. This can be monitored here:https://health.aws.amazon.com/health/status.

This has resulted in degraded performance or limited access to certain features. Our team is actively monitoring the situation and will provide updates as AWS restores normal operations. We apologize for the inconvenience and appreciate your patience.